Topics

6.07.09 will not launch


Darth Borehd
 

I just downloaded the full version of 6.07.09 and it will not launch.  The 6.07.08 works fine.  I get the following error message.  How can I fix it?  

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: pcgen/system/Main has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)



Paul Grosse
 


saxumcaribetum
 

On 2018-10-17 14:52, nylanfs@... [pcgen] wrote:
Did you also download and install java 10?


Sticking my nose in, and trying the link.
(I currently have Java 8...)
Oops!!

I followed the link above, which takes me to the Oracle Java SE Runtime Environment for  the JRE 10.0.2
That expands a list of downloads, including the ones applicable to me, for WIndows 64-bit.

However, clicking the link on the Oracle page gives a
"We're sorry, the page you requested was not found.
We have recorded this error (404) to help us fix the problem."

Does PCGen run OK with Java 11, or is the current version dependent on specific Java 10 features?


---------------------------

Oops! Java 11 isn't very friendly
They want people to use the OpenJDK unless they are commercial.


Any idea what's going on?
 
-- 
Neil Taylor "Creo Imaginem Mente"
ArM Code 1.5 5++ Ca++ R++p H++ ?L Y(96) T(5)- SG+++ G++++ P++ HoH(Ma++ Q+ Hg+) Fz(E)++ C++ :-) Cd++
Saga site at http://homepage.ntlworld.com/saxum.caribetum/
Sub Rosa Ars Magica zine - https://www.facebook.com/subrosamagazine/


Darth Borehd
 

No, I'll give it a try.  Is it required now?  I am reluctant to use because it might break other programs.  


On Wed, Oct 17, 2018 at 12:16 PM Saxum Caribetum saxum.caribetum@... [pcgen] <pcgen@...> wrote:
 

On 2018-10-17 14:52, nylanfs@... [pcgen] wrote:
Did you also download and install java 10?


Sticking my nose in, and trying the link.
(I currently have Java 8...)
Oops!!

I followed the link above, which takes me to the Oracle Java SE Runtime Environment for  the JRE 10.0.2
That expands a list of downloads, including the ones applicable to me, for WIndows 64-bit.

However, clicking the link on the Oracle page gives a
"We're sorry, the page you requested was not found.
We have recorded this error (404) to help us fix the problem."

Does PCGen run OK with Java 11, or is the current version dependent on specific Java 10 features?


---------------------------

Oops! Java 11 isn't very friendly
They want people to use the OpenJDK unless they are commercial.


Any idea what's going on?
 
--
Neil Taylor "Creo Imaginem Mente"
ArM Code 1.5 5++ Ca++ R++p H++ ?L Y(96) T(5)- SG+++ G++++ P++ HoH(Ma++ Q+ Hg+) Fz(E)++ C++ :-) Cd++
Saga site at http://homepage.ntlworld.com/saxum.caribetum/
Sub Rosa Ars Magica zine - https://www.facebook.com/subrosamagazine/


David
 

Yes. Read the release notes.



Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: "Darth Borehd darth.borehd@... [pcgen]" <pcgen@...>
Date: 10/17/18 17:56 (GMT-05:00)
To: pcgen@...
Subject: Re: [pcgen] Re: 6.07.09 will not launch

No, I'll give it a try.  Is it required now?  I am reluctant to use because it might break other programs.  


On Wed, Oct 17, 2018 at 12:16 PM Saxum Caribetum saxum.caribetum@... [pcgen] <pcgen@...> wrote:
 

On 2018-10-17 14:52, nylanfs@... [pcgen] wrote:
Did you also download and install java 10?


Sticking my nose in, and trying the link.
(I currently have Java 8...)
Oops!!

I followed the link above, which takes me to the Oracle Java SE Runtime Environment for  the JRE 10.0.2
That expands a list of downloads, including the ones applicable to me, for WIndows 64-bit.

However, clicking the link on the Oracle page gives a
"We're sorry, the page you requested was not found.
We have recorded this error (404) to help us fix the problem."

Does PCGen run OK with Java 11, or is the current version dependent on specific Java 10 features?


---------------------------

Oops! Java 11 isn't very friendly
They want people to use the OpenJDK unless they are commercial.


Any idea what's going on?
 
-- 
Neil Taylor "Creo Imaginem Mente"
ArM Code 1.5 5++ Ca++ R++p H++ ?L Y(96) T(5)- SG+++ G++++ P++ HoH(Ma++ Q+ Hg+) Fz(E)++ C++ :-) Cd++
Saga site at http://homepage.ntlworld.com/saxum.caribetum/
Sub Rosa Ars Magica zine - https://www.facebook.com/subrosamagazine/